s3 logs empty?

seems that only the first day of logs got retrieved. I made a point to download a file yesterday and the log still says 0kb.

Could you look into this please?

aclark
Sunday, December 21, 2008




Looks like you ran into a known issue with S3Fox.

S3Fox has a flaw in the way it sets Access Control Policies. S3 requires that the permission "READ_ACP" be set for a bucket to allow Server Access Logging. S3Fox is unaware of this value, and will reset it to "READ" whenever you make a change to the ACL for a bucket.

We've informed the S3Fox developer of this issue several times, but as of yet haven't received so much as a response.

I've fixed your bucket by hand, but if this happens again you can get yourself back up and running from your MyAccount page. Simply disable, then re-enable logging for the bucket in question. That will put the ACL back where it belongs, and allow Amazon to continue delivering logfiles.

Jason

jason
Monday, December 22, 2008




cool thanks, any way to retry the last 4 days logs? I had used s3fox at first but have not used it recently.


aclark
Monday, December 22, 2008




I just re-read what you said, from what I understand amazon was not creating them so there would be nothing you can do.

Thanks!

aclark
Monday, December 22, 2008




Yeah, that's correct. Sorry to disappoint.

I just pushed out a new release that will check every bucket every night to see if S3Fox has messed up its ACL, and fix it if necessary. So, with luck, this will stop being an issue.

Jason

jason
Tuesday, December 23, 2008




I too am having trouble with our logs. They stopped accumulating on 1/20 (the same day we signed up with S3Stat, but not sure if the two events are related).

I can't find anything under MyAccount to disable/enable logging. Am I looking in the wrong place?

Roy

markspace
Monday, February 2, 2009




On your MyAccount page, each of your buckets should have a little snippet of green text saying:

S3 Logging Enabled

(or red text saying Disabled). Under that will be a link titled "disable" or "enable". Click & verify a couple times, and you will have toggled logging for the bucket and reset any permissions for it.


jason
Friday, February 6, 2009

[ reply to this topic ]   [ return to topic list ]

© 2021 Expat Software Back to Top