Not showing logfiles

I enabled logging in my s3 buckets. The actual logs are sent to another bucket, for security purposes. How can I not show the actual "log files" in s3stat. Right now my s3 bucket files and logfiles are being reported on s3stat. Showing actual logfiles on s3stat is a waste and not what we want.
Tuesday, May 10, 2016

It looks like you figured this out on your own, but I'll answer your question here in case anybody else runs in to the same issue.

Setting up logging to another bucket is a good plan in general, since it keeps your source bucket free of logfiles. It also means that when you set up S3stat reporting, we won't report on traffic to those logfiles.

The important point is that you need to set up logging on the *source bucket*, not the logging bucket. As many people have found out, reading reports about Amazon delivering logfiles and us reading them each day is not very interesting, but that's what you'll get if you set up your log bucket for reporting.

Jason Kester
Tuesday, July 19, 2016

[ reply to this topic ]   [ return to topic list ]

© 2018 Expat Software Back to Top